$re = '/\[docker[\s\S]+(?=\[)/';
$str = '[test_servers]
67.205.130.201
[dockercloud_servers]
x
y
[redis_servers]
x
x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);