$re = '/.*\s[^\s]+\s([0-9\-]{5,})/m';
$str = 'My phone number is 4553333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);