$re = '/^0*10*10*10*10*$/m';
$str = '0110101000
010110
011011011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);