package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href\s?=\s?"\s?([\S\s]+)"`)
var str = `href="http://somedomain.com/subscription/some-report-text/issue/the-deadliest-word-on-the-
planet-could-bring-savvy-investors-extraordinary-profits/?u=000071340856&vid=TatDiU&a=MMP&o=9637385?u=000071340856&vid=8ALdFM&a=MMP&o=6530827?u=000071340856&vid=9Vm2j_&a=MMP&o=1652570?u=000071340856&vid=Cd_ME9&a=MMP&o=8995371"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}