re = /^(?=\S{3,15}$)[a-zA-Z][a-zA-Z0-9]*(?:[_.-][a-zA-Z0-9]+)?$/m
str = 'a
a.
ab
a.b.c
abc
a.by
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end