package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[1-9][0-9]|[1-9][0-9][0-9]|[1-9][0-9][0-9][0-9]){4}\d{25}[0-9]{1}\d{12}([1-9]|[1-9][0-9]|[1-9][0-9][0-9])$`)
var str = `26090837916945379538252700000004491630000002580`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}