$re = '/\b\d{1,4}(?:\.\d{1,4})?px/';
$str = '.some_class {
font-size: 11px;
margin-left: 0.45px;
margin-top:11.0005px;
border: 1.1px solid blue;
}
.another_class {
background: rgba(0, 0, 0, 0.2);
width: 100%;
color: #012345;
z-index: 12;
font-size: calc(100% + 888.888px);
}
12345678px';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);