$re = '/^-?[0-9\b]+(\.\d{0,2})?$/m';
$str = '12.12
-9.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);