package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`7`)
var str = `6776`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}