$re = '/.*?\.(\d+)\./m';
$str = 'xxx.12345.Date.zzz.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);