$re = '/(?ms)(?<Connection>^\d+)\s+IKE\sPeer[\s:]+(?<IKEPeer>[\d\.]+\s\([\w ]+\)).+?Type[\s:]+(?<Type>[\w]+)\s+Role[\s:]+(?<Role>\w+).+?Rekey[\s:]+(?<Rekey>\w+)\s+State[\s:]+(?<State>\w+).+?Encrypt[\s:]+(?<Encrypt>[\w-]+)\s+Hash[\s:]+(?<Hash>\w+).+?Auth[\s:]+(?<Auth>\w+)\s+Lifetime[\s:]+(?<Lifetime>\d+).+?Lifetime\sRemaining[\s:]+(?<LifetimeRemaining>\d+)/mx';
$str = '1 IKE Peer: 192.168.8.188 (PHX2)
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE
Encrypt : 3des Hash : SHA
Auth : preshared Lifetime: 86400
Lifetime Remaining: 52140
2 IKE Peer: 192.168.8.189 (Worcester)
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE
Encrypt : aes-256 Hash : SHA
Auth : preshared Lifetime: 28800
Lifetime Remaining: 5929
3 IKE Peer: 192.168.8.190 (Fresno)
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE
Encrypt : aes-256 Hash : SHA
Auth : preshared Lifetime: 28800
Lifetime Remaining: 6564
4 IKE Peer: 192.168.8.191 (San Leandro)
Type : L2L Role : initiator
Rekey : no State : MM_ACTIVE
Encrypt : 3des Hash : SHA
Auth : preshared Lifetime: 86400
Lifetime Remaining: 71608';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);