package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`sue, smith`)
var str = `sue, smith shelly`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}