using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/begin MEASUREMENT ([\w.]+).*\nSWORD ([\w.]+) \d+ \d+ (-?\d+(?:\.\d+)?) (-?\d+(?:\.\d+)?)";
string input = @"/begin MEASUREMENT ANY.NAME1 ""Unterstützungskraft Softwaremodul ""
SWORD ANYN.AME2 1 100 -2342342523 -14.29";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}