$re = '/\b(\p{L}+)(?:,\s*\1)+\b/mu';
$str = 'Ryan, Ryan needs to find his papers
Żaneta,Żaneta, Żaneta needs to find his papers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);