import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-z0-9](?:[a-z0-9-]{0,61}[a-z0-9])?\\.)+[a-z0-9][a-z0-9-]{0,61}[a-z0-9]";
final String string = "Valid domain name matching.\n"
+ "Vote for it: http://stackoverflow.com/a/30007882/697313\n\n"
+ "Sample text for testing:\n"
+ "abcdefghijklmnopqrstuvwxyz.ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "0123456789 +-.,!@#$%^&*();\\\\/|<>\\\"\\'\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "555.123.4567 +1-(800)-555-2468\n"
+ "foodemo.net\n"
+ "bar.ba.test.co.uk\n"
+ "www.demo.com\n"
+ "http://foo.co.uk/\n"
+ "http://regexr.com/foo.html?q=bar\n"
+ "g.com\n"
+ "g-.com\n"
+ "com.g\n"
+ "-g.com\n"
+ "xn--d1ai6ai.xn--p1ai\n"
+ "xn-fsqu00a.xn-0zwm56d\n"
+ "xn--stackoverflow.com\n"
+ "stackoverflow.xn--com\n"
+ "stackoverflow.co.uk\n"
+ "google.com.au\n\n"
+ "-0-0o.com\n"
+ "0-0o_.com (underscore not allowed)\n"
+ "a.net\n"
+ "-a.dot\n"
+ "0-0o.com\n"
+ "0-oz.co.uk\n"
+ "0-tension.com.br\n"
+ "0-wh-ao14-0.com-com.net\n"
+ "a-1234567890-1234567890-1234567890-1234567890-1234567890-1234-z.eu.us\n"
+ "a-1234567890-1234567890-1234567890-1234567890-1234567890-12345-z.eu.us (too long)\n\n"
+ "List of valid domain names:\n"
+ "www.google.com\n"
+ "google.com\n"
+ "mkyong123.com\n"
+ "mkyong-info.com\n"
+ "sub.mkyong.com\n"
+ "sub.mkyong-info.com\n"
+ "mkyong.com.au\n"
+ "g.co\n"
+ "mkyong.t.t.co\n\n"
+ "List of invalid domain names, and why:\n"
+ "mkyong.t.t.c – Tld must between 2 and 6 long\n"
+ "mkyong,com – Comma is not allow\n"
+ "mkyong – No Tld\n"
+ "mkyong.123 , Tld not allow digit (can easily fix for this)\n"
+ ".com – Must start with [A-Za-z0-9]\n"
+ "mkyong.com/users – No Tld\n"
+ "-mkyong.com – Cannot begin with a hyphen -\n"
+ "mkyong-.com – Cannot end with a hyphen -\n"
+ "sub.-mkyong.com – Cannot begin with a hyphen -\n"
+ "sub.mkyong-.com – Cannot end with a hyphen -\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}