re = /(.)(?!\1)(.)(?!\1)(?!\2)(.)(?!\1)(?!\2)(?!\3)(.)/m
str = 'ABCA
ABABCB
ABCABCD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end