# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=[a-z])[a-z0-9_]*$(?<=[a-z0-9])"
test_str = ("This regex match correct nicknames:\n\n"
"username\n"
"username16\n"
"But can't match like this correct nicknames:\n\n"
"username_16\n"
"In generaly how rewrite my regex for regx which can ignore sample wrong user names:\n\n"
"16username\n"
"_username\n"
"username_\n"
"User nickname string on start can contain only a-z letters and in the middle (center) of string can contain a-z0-9_ and on the end can contain only a-z0-9\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.