package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*cat|^`)
var str = `dog
cat
wildcat
thundercat
cow
hooo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}