$re = '/cat(?=[\s.,]?mouse\b)/m';
$str = 'catmouse
cat mouse
cat,mouse
cat.mouse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);