$re = '/(?=((?:\.\d|^).*))/m';
$str = '21.01.8.6.5.2.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);