import re
regex = re.compile(r"^(?=Name:)(.*?)(?=USB Device Filters:)", flags=re.MULTILINE | re.DOTALL)
test_str = ("Name: Server1 10.0.0.11\n"
"Groups: /\n"
"Guest OS: Ubuntu (64-bit)\n"
"\\n\n"
"<none>\n"
"USB Device Filters:\n\n"
"Name: Server2 10.0.0.12\n"
"Groups: /\n"
"Guest OS: Debian (64-bit)\n"
"\\n\n"
"<none>\n"
"USB Device Filters:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")