re = /\S+@\S+\.\S+\.\S+/m
str = 'abc@aaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end