re = /(?:[\/](?:(?:\\\\)|(?:\\\/)|(?:[^\\\/]))+)/m
str = '/./sub/sub2\\//sub3\\\\/sub4\\\\\\/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end