re = /(?<=<)[^<>\s|]+/m
str = 'This is the link <stackoverlflow.com>
This is the link <https://stackoverlflow.com>
This is the link <stackoverlflow.com | Click here>
This is the link <https://stackoverlflow.com | Click here>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end