# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<= )[\w.]+$)(?=[\s\S]*(?<= )(\1)$)"
test_str = ("src/test/resources\n"
"|-- WPCDPS\n"
"| `-- RiskIndicatorsEvaluationRuleTest.feature\n"
"|-- Accelerated.feature\n"
"|-- AcceptedAFS.feature\n"
"|-- AgeValidationRemoval.feature\n"
"|-- Anxiety.feature\n"
"|-- CheckDisabledOccupation.feature\n"
"|-- Extended.feature\n"
"|-- Financal.feature\n"
"|-- Fainancial.feature\n"
"|-- FloridaSpecific.feature\n"
"|-- Hypertension.feature\n"
"|-- LifeForceOrPending.feature\n"
"|-- LifestyleInformation.feature\n"
"|-- MinValue.feature\n"
"|-- Occupations\n"
"| |-- OccupationTranslation.feature\n"
"| |-- OccupationsWithPreConditions.feature\n"
"| |-- Accelerated.feature\n"
"| `-- OccupationsWithoutPreConditions.feature\n"
"|-- Florida.feature")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.