package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[“"]([A-Za-z0-9.-][A-Za-z,:’]*(?:\s+[A-Za-z0-9.-][A-Za-z,:’]*){4,})[”"]`)
var str = `Attorney General William Barr said the volume of information compromised was “staggering” and the largest breach in U.S. history.“This theft not only caused significant financial damage to Equifax but invaded the privacy of many, millions of Americans and imposed substantial costs and burdens on them as they had to take measures to protect themselves from identity theft,” said Mr. Barr.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}