package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*([^;]+\b[1-9]\d*%)`)
var str = `ABCD 0% #@x; EDFG 0% #@x; HIGK 5% #@x; LMNO 50% #@x; PQRS 90%; TUVW 0% #@x;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}