$re = '/["|\']|\[|\]/m';
$str = '[mysql,"redis",\'db\']';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;