$re = '/(?=(10[01]\d{7}))/';
$str = '1010159552597';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);