# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-\s\*financial\:\*"
test_str = ("- *Financial:* <yes or no. If yes, explain why>\n"
"- *Legal/Regulatory:* <yes or no. If yes, explain why>\n"
"- *Data Integrity:* <yes or no. If yes, explain why>\n"
"- *Patient Safety:* <yes or no. If yes, explain why>\n"
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>\n\n"
"- *Financial:* <yes/no>\n"
"- *Legal/Regulatory:* <yes/no>\n"
"- *Data Integrity:* <yes/no>\n"
"- *Patient Safety:* <yes/no>\n"
"- *CyberSecurity/Information Security:* <yes/no>\n\n"
"- *Financial:* <yes or no. If yes, explain why>No\n"
"- *Legal/Regulatory:* <yes or no. If yes, explain why> Yes\n"
"- *Data Integrity:* No\n"
"- *Patient Safety:* Yes, this was an issue because of XYZ.\n"
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why>\n\n"
"- *Financial:* no\n"
"- *Legal/Regulatory:* no\n"
"- *Data Integrity:* no\n"
"- *Patient Safety:* no\n"
"- *CyberSecurity/Information Security:* no\n\n"
"- *Financial:* N\n"
"- *Legal/Regulatory:* N\n"
"- *Data Integrity:* N\n"
"- *Patient Safety:* N\n"
"- *CyberSecurity/Information Security:* N\n\n"
"- *Financial:* <yes or no. If yes, explain why>N\n"
"- *Legal/Regulatory:* <yes or no. If yes, explain why> N\n"
"- *Data Integrity:* <yes or no. If yes, explain why>N\n"
"- *Patient Safety:* <yes or no. If yes, explain why>N\n"
"- *CyberSecurity/Information Security:* <yes or no. If yes, explain why> N\n\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.