$re = '/(?:[\s\S]*)(\{(.*?)\}(.*?)p\. [0-9]+)/m';
$str = '{Hello}, [123:456] (Test). This is stample data used to answer a
question {Hello2} [Ch.8 p. 87';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);