import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((.|\\n)*)(a\\).*?)\\n*?(b\\).*?)\\n*?(c\\).*?)\\n*?(d\\).*?)\\n*?(e\\).*?)$|\\n";
final String string = "pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta\n\n"
+ "pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta\n\n"
+ "a) resposta a\n"
+ "b) resposta b \n"
+ "c) resposta c\n"
+ "d) resposta d\n"
+ "e) resposta e";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}