re = /(\d)(?=\1)|\d(?=(\d)(?!\2))|\d(?=\d(\d)\3)|\d(?=(\d{2})\d)/m
str = '112322566678443177a22
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end