$re = '/(\d)(?!\1)(\d)\2(?!\2)\d/m';
$str = '112322566678443177a22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);