$re = '/^([A-Za-z0-9+\/]{4})*([A-Za-z0-9+\/]{4}|[A-Za-z0-9+\/]{3}=|[A-Za-z0-9+\/]{2}==)$/';
$str = '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';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);