$re = '/^([a-z\!\$\#\*\d]){8,64}(?=$)/mi';
$str = 'Coolgman#12
HelloWorld$#
#fdaijopfadl
fdka;%dfkajspfdsalk;fajdsip
gdkalafdksl12ie3ofda#$!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);