$re = '/[^\s@]@([^\s@]+)\.[a-z]{2,}/m';
$str = 'email@example.com
email@ex.ample.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);