package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<CI_V2>[^;]*);(?<CI_1>[^;]*);(?<CI_2>[^;]*);(?<CI_3>[^;]*);(?<CI_4>[^;]*);(?<CI_5>[^\"]*)`)
var str = `"CI": "V2;Y;Windows;srv048;LogicalDisk;C:",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}