# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\[img.*?\].*?photobucket.*?.jpg)(\[\/img.*?\])"
test_str = ("Connecting rod fitted to prevent steering tie rod from cranking:\n"
"[url=http://s557.photobucket.com/user/realboss7669/media/F707F408-829F-48B9-9AED-BB57CEFF96C0_zpslwioah0z.jpg.html:jaeyh8wg][img:jaeyh8wg]http://i557.photobucket.com/albums/ss16/realboss7669/F707F408-829F-48B9-9AED-BB57CEFF96C0_zpslwioah0z.jpg[/img:jaeyh8wg][/url:jaeyh8wg]\n\n"
"From the rear:\n"
"[url=http://s557.photobucket.com/user/realboss7669/media/05AE0DB2-83FD-4B2C-9FDA-E3257DFEB832_zpsc6cfuqwi.jpg.html:jaeyh8wg][img:jaeyh8wg]http://i557.photobucket.com/albums/ss16/realboss7669/05AE0DB2-83FD-4B2C-9FDA-E3257DFEB832_zpsc6cfuqwi.jpg~original[/img:jaeyh8wg][/url:jaeyh8wg]\n\n"
"Steering damper mounts finished - without the connecting rod the damper would get bent:\n"
"[url=http://s557.photobucket.com/user/realboss7669/media/C85A0F5D-413D-4779-9F09-BD43BB798238_zpse8s6dxyu.jpg.html:jaeyh8wg][img:jaeyh8wg]http://i557.photobucket.com/albums/ss16/realboss7669/C85A0F5D-413D-4779-9F09-BD43BB798238_zpse8s6dxyu.jpg[/img:jaeyh8wg][/url:jaeyh8wg]\n\n"
" <!-- s8) --><img src=\"{SMILIES_PATH}/icon_cool.gif\" alt=\"8)\" title=\"Cool\" /><!-- s8) -->")
subst = "$1~original$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.