$re = '/(%>\R*|\G\R*(?!<%))./m';
$str = 'a<% some important text %> something <% important stuff %>
not impo<%abc%>rtant stuf
f <not important stuff>
<% some
important text
%>
<not important stuff>';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;