# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((S|T)([a-zA-Z0-9]{9})|([0-3])(\d{8})([A-Z]))//g;t' <<< "000000000A
399999999Z
S000000000
TZZZZZZZZZ
T0GBA12348
A123456672
S201562837
201902938G
T19SS0110H
T19SS0025B
"