re = /(?:")(?=(?:[^"]|"[^]*")*$)/m
str = 'newX {"lol": "whatevr"}
str {"lol": "hey"\'there"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end