#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix) (?(DEFINE)" & @CRLF & _
" (?<unreserved>[a-z0-9_~\-]) # . is missing as it is used to separate labels" & @CRLF & _
" (?<sub_delims>[!$&'()*+,;=])" & @CRLF & _
" (?<encoded>%[A-F0-9]{2})" & @CRLF & _
" (?<reg_name>(?:(?&unreserved)|(?&sub_delims)|(?&encoded))*)" & @CRLF & _
" )" & @CRLF & _
" ^(?:(?®_name)\.)*(?®_name)\.?$"
Local $sString = "_example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")