$re = '/[0-9]{2,3}(\s|-)[0-9]{4,5}-?[0-9]{3,4}/m';
$str = '\'00 00000000\'
\'000-000000000\'
\'000 00000-0000\'
\'00 0000-0000\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);