import re
regex = re.compile(r"^([A-Z][a-z]{2}\s\d\s\d\d:[\d]{2}:[\d]{2})\s([\w]+[\.][\w]+)\s([\w|=]+)(\[\d+\]):\s.+[\(|\s|\\|\"]", flags=re.MULTILINE)
test_str = ("Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)\n"
"Jul 6 14:02:08 computer.name jam_tag=psim[29187]: (UUID:006)\n"
"Jul 6 14:02:09 computer.name jam_tag=psim[29187]: (UUID:007)\n"
"Jul 6 14:03:01 computer.name CRON[29440]: USER (naughty_user)\n"
"Jul 6 14:03:40 computer.name cacheclient[29807]: start syncing from \\\"0xDEADBEEF\\\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")