$re = '/<(i|em)>.+?<\/\1>/m';
$str = '<i>Fares</i><em>Alarabi</em>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);