re = /(?i)\bUsername\s*[:;]\s*(\S+)/m
str = 'Username:dasdsad
username ;dasdsad
username : dasdsad
username; dasdsad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end