#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\-\-)((main|next|staging|dev(elop)?|test(ing)?)$|^((feat(ure)?|(bug|hot)?fix|docs|wip|test(ing)?)\/(?!\-)([a-z0-9\-]{1,50}(?<!-)\/(?!\-))?[a-z0-9\-]{1,100}(?<!-))$|^release\/v?(0|[1-9]\d*)\.(0|[1-9]\d*)\.(0|[1-9]\d*)(?:-((?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?(?:\+([0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?)$"
Local $sString = "main" & @CRLF & _
"next" & @CRLF & _
"staging" & @CRLF & _
"dev" & @CRLF & _
"develop" & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"feat/lorem-ipsum" & @CRLF & _
"feature/dolorm" & @CRLF & _
"test/a-separate-branch-just-to-test-a-new-feature" & @CRLF & _
"bugfix/182-this-and-that" & @CRLF & _
"wip/work-in-progress-but-for-some-reason-someone-made-a-branch" & @CRLF & _
"fix/correct-branch" & @CRLF & _
"bugfix/517/alternative-bugfix-thingy" & @CRLF & _
"" & @CRLF & _
"docs/reference/this-is-just-on-the-verge-of-being-way-too-long-but-it-is-still-acceptable-as-its-under-a-hundred" & @CRLF & _
"docs/reference/this-is-just-on-the-verge-of-being-way-too-long-but-it-is-still-acceptable-as-its-exactly-hundred-ch" & @CRLF & _
"" & @CRLF & _
"hotfix/cannot-end-with-a-dash-" & @CRLF & _
"docs/no-consecutive-dashes" & @CRLF & _
"" & @CRLF & _
"release/v1.0.0" & @CRLF & _
"release/1.0.0" & @CRLF & _
"release/v1.0.0-alpha.12" & @CRLF & _
"release/5123.1.5-some-meta-data" & @CRLF & _
"" & @CRLF & _
"docs/gfdgdfs-" & @CRLF & _
"" & @CRLF & _
"release" & @CRLF & _
"docs//no-consecutive-slashes" & @CRLF & _
"dev/invalid" & @CRLF & _
"wrong/im-wrong" & @CRLF & _
"docs/Bad-Casing" & @CRLF & _
"release/invalid_characters" & @CRLF & _
"docs/reference/this-one-is-obviously-just-way-too-long-to-make-sense-or-to-be-at-all-considered-by-the-expression-to-be-correct-as-its-very-clearly-not-correct-at-all" & @CRLF & _
"feat/cannot-end-with-a-slash/" & @CRLF & _
"docs/one/too/many/slashes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")