$re = '/^([A-B=]+\s)([0-9]+|)/m';
$str = '"
......
A=
B= 12345
....."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);