$re = '/((\d)|(A-Z)){8}/m';
$str = '12345678
1234567A-Z
A-ZA-ZA-ZA-ZA-ZA-ZA-ZA-Z
ASDFGHJK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);